2005 Equinox not starting - EquinoxForum.net: Chevy Equinox Forum
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 06-16-2012, 08:06 PM Thread Starter
Newbie
 
Join Date: Jun 2012
Posts: 1
2005 Equinox not starting

Hi everyone,

Sorry if this is the wrong place/forum for this question...I'm a little worked up to say the least and am hoping I can get some help.

For the past week, my Equinox is having problems starting. The starter "clicks" when the key is fully turned, and clicks when it returns to the "on" position, but there's simply no ignition. Some times, it'll start first-shot. Sometimes, it'll start when I turn the key slowly back to the "on" position. But sometimes (like today) nothing I can do will start the thing. As I said, I hear the starter click, but there's simply no ignition. When it does start and take it for a drive, it has never stalled. There's no problem with acceleration or anything like that. I just replaced the old battery with a brand new one, and the electronics are fine. Any thoughts?
andrewc is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-16-2012, 08:25 PM
Theta GOD!
 
Join Date: Jan 2010
Posts: 7,840
Re: 2005 Equinox not starting

Quote:
Originally Posted by andrewc
Hi everyone,

Sorry if this is the wrong place/forum for this question...I'm a little worked up to say the least and am hoping I can get some help.

For the past week, my Equinox is having problems starting. The starter "clicks" when the key is fully turned, and clicks when it returns to the "on" position, but there's simply no ignition. Some times, it'll start first-shot. Sometimes, it'll start when I turn the key slowly back to the "on" position. But sometimes (like today) nothing I can do will start the thing. As I said, I hear the starter click, but there's simply no ignition. When it does start and take it for a drive, it has never stalled. There's no problem with acceleration or anything like that. I just replaced the old battery with a brand new one, and the electronics are fine. Any thoughts?
I would check the ground connection from the battery to the car's frame, then the Positive connection from the battery to the starter- in fact clean all of the connections at the starter, and if it still doesn't start, then I would start trying to replace the ignition switch. That is in order of difficulty, and cost.

2010 Equinox LTZ<br />4 cyl, FWD, S/R<br />Cardinal Red/Black
RIT333 is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the EquinoxForum.net: Chevy Equinox Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome