2010 Equinox 2.4 P0017 code - EquinoxForum.net: Chevy Equinox Forum
Reply
 
LinkBack Thread Tools
post #1 of 18 (permalink) Old 04-05-2017, 10:01 AM Thread Starter
Jr. Member
 
Join Date: Apr 2017
Posts: 21
2010 Equinox 2.4 P0017 code

I bought a 2010 Equinox awd 2.4L a little over a month ago. It is throwing a P0017 cam / crank correlation code. The timing chain, cam sensors, crank sensor, and vvt solenoids have been replaced, and it continues to throw the code. The only problem we have is it doesn't always start the first time you turn the key. It will crank, but not start. Sometimes it will start right up, sometimes it takes 2 or 3 tries for it to start. Other than that, it runs great, no misses, no loss of power, gas mileage where it should be... We're at a loss on where to go from here, because everything has been done. Any insight?
hayners334 is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old 04-05-2017, 11:55 AM
Sr. Member
 
Join Date: Nov 2016
Posts: 408
Re: 2010 Equinox 2.4 P0017 code

I assume that the battery is good?
That would explain the startup issue.

Jeff from Iowa, Purchased 2011 Nox in Nov. 2016, Manufacture date 10-10, 2.4l, AWD
New to the Nox is offline  
post #3 of 18 (permalink) Old 04-05-2017, 12:16 PM Thread Starter
Jr. Member
 
Join Date: Apr 2017
Posts: 21
Re: 2010 Equinox 2.4 P0017 code

Battery is good, so that's not an issue. We just cant seem to get rid of the P0017 code after replacing everything. That's the only code showing, and it's a "permanent" code, which from what I've read has a specific drive cycle you have to do to completely clear the code, you cannot clear it with a scan tool. Anyone know anything about that?
hayners334 is offline  
Sponsored Links
Advertisement
 
post #4 of 18 (permalink) Old 04-05-2017, 01:24 PM
Theta Freak
 
rednox301's Avatar
 
Join Date: Nov 2014
Posts: 1,039
Re: 2010 Equinox 2.4 P0017 code

This is a list of most comon causes of DTC P0017:

Cam Position Actuator Sol Valve stuck in advance or retard position.
Correct installation of Cam Pos Act Sol Valves.
Correct installation of Cam Position Sensors.
Correct installation of Crankshaft Position Sensor.
A timing chain tensioner condition.
An incorrectly installed timing chain.
Excessive play in timing chain.
A crankshaft reluctor wheel moved in relation to top dead center on the crankshaft.

2014 Equinox LTZ FWD 3.6L. V-6 (LFX)
GM6T70 Transmission-Gen II(M7W)
Crystal Red Tintcoat-Brownstone Leather-(FE2) Suspension-18" Wheels
Build Date: Nov. 04, 2013-Delivery Date: Nov. 25, 2013
rednox301 is offline  
post #5 of 18 (permalink) Old 04-05-2017, 01:35 PM
Theta Freak
 
rednox301's Avatar
 
Join Date: Nov 2014
Posts: 1,039
Re: 2010 Equinox 2.4 P0017 code

Quote:
Originally Posted by hayners334
Battery is good, so that's not an issue. We just cant seem to get rid of the P0017 code after replacing everything. That's the only code showing, and it's a "permanent" code, which from what I've read has a specific drive cycle you have to do to completely clear the code, you cannot clear it with a scan tool. Anyone know anything about that?
Check out link below


http://www.obdii.com/drivecycle.html

2014 Equinox LTZ FWD 3.6L. V-6 (LFX)
GM6T70 Transmission-Gen II(M7W)
Crystal Red Tintcoat-Brownstone Leather-(FE2) Suspension-18" Wheels
Build Date: Nov. 04, 2013-Delivery Date: Nov. 25, 2013
rednox301 is offline  
post #6 of 18 (permalink) Old 04-06-2017, 02:02 PM Thread Starter
Jr. Member
 
Join Date: Apr 2017
Posts: 21
Re: 2010 Equinox 2.4 P0017 code

Quote:
Originally Posted by rednox301
This is a list of most comon causes of DTC P0017:

Cam Position Actuator Sol Valve stuck in advance or retard position.
Correct installation of Cam Pos Act Sol Valves.
Correct installation of Cam Position Sensors.
Correct installation of Crankshaft Position Sensor.
A timing chain tensioner condition.
An incorrectly installed timing chain.
Excessive play in timing chain.
A crankshaft reluctor wheel moved in relation to top dead center on the crankshaft.
All of this has been replaced and checked, all is good. Just can't get rid of the code, which means my remote start won't work because the MIL is on. Only other issue is that it won't start first time every time. Sometimes it starts fine, sometimes 2 to 3 tries before it starts. No other issues, mileage is as it should be, runs great, no noises, no misses, nothing. Only the P0017 and intermittent not starting first time.
hayners334 is offline  
post #7 of 18 (permalink) Old 04-08-2017, 10:07 PM Thread Starter
Jr. Member
 
Join Date: Apr 2017
Posts: 21
Re: 2010 Equinox 2.4 P0017 code

UPDATE-
Issue has been mostly taken care of. Replaced the(new) exhaust cam sensor, began starting first try more often. Put a scanner on it, and was throwing a crank sensor code. Replaced(again, new) crank sensor, and it now starts first try every time. Permanent code is still there, but is going to the dealer next week to have the drive cycle done to delete that code if it doesn't clear itself before then.
hayners334 is offline  
post #8 of 18 (permalink) Old 04-09-2017, 12:18 PM
Theta Freak
 
rednox301's Avatar
 
Join Date: Nov 2014
Posts: 1,039
Re: 2010 Equinox 2.4 P0017 code

Quote:
Originally Posted by hayners334
UPDATE-
Issue has been mostly taken care of. Replaced the(new) exhaust cam sensor, began starting first try more often. Put a scanner on it, and was throwing a crank sensor code. Replaced(again, new) crank sensor, and it now starts first try every time. Permanent code is still there, but is going to the dealer next week to have the drive cycle done to delete that code if it doesn't clear itself before then.
Good to see that you are closing in on the problem.

I have been doing some reading since my reply #3.
It seems this code can only set if the ECM sees a mechanical advance or retard of more than 10 degrees.
It is either one of the components on that list, a bad sensor, or the ECM is not processing the sensor info properly.

Because P0017 is a Type B DTC it may clear itself, good luck.

2014 Equinox LTZ FWD 3.6L. V-6 (LFX)
GM6T70 Transmission-Gen II(M7W)
Crystal Red Tintcoat-Brownstone Leather-(FE2) Suspension-18" Wheels
Build Date: Nov. 04, 2013-Delivery Date: Nov. 25, 2013
rednox301 is offline  
post #9 of 18 (permalink) Old 04-09-2017, 01:15 PM
Sr. Member
 
Join Date: Nov 2016
Posts: 408
Re: 2010 Equinox 2.4 P0017 code

Quote:
Originally Posted by hayners334
UPDATE-
Issue has been mostly taken care of. Replaced the(new) exhaust cam sensor, began starting first try more often. Put a scanner on it, and was throwing a crank sensor code. Replaced(again, new) crank sensor, and it now starts first try every time. Permanent code is still there, but is going to the dealer next week to have the drive cycle done to delete that code if it doesn't clear itself before then.
I seen your post about oil consumption.
This can be directly related to your issue here.
The cam actuator runs off of the oil. If oil is low.....

Jeff from Iowa, Purchased 2011 Nox in Nov. 2016, Manufacture date 10-10, 2.4l, AWD
New to the Nox is offline  
post #10 of 18 (permalink) Old 04-09-2017, 05:41 PM
Theta Guru
 
JayTee2014's Avatar
 
Join Date: Sep 2014
Posts: 3,498
Re: 2010 Equinox 2.4 P0017 code


<br />2015 Equinox LTZ 3.6L FWD Champagne Silver Metallic *Build Date 1-08-2015&nbsp; * * 20,300 miles
JayTee2014 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the EquinoxForum.net: Chevy Equinox Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome