EquinoxForum.net Bookmark and Share
November 01, 2014, 06:04:57 AM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Forum Tip: Click the little blue 'new' icon next to any topic to jump right to the first unread message.
   
   Home   Help Search Gallery Login Register  
Registered users see fewer ads.
Pages: [1]   Go Down
  Print  
Author Topic: Wiper arm issue  (Read 3815 times)
0 Members and 1 Guest are viewing this topic.
bradvincent
Newbie
*
Offline Offline

Posts: 4




Ignore
« on: September 22, 2011, 12:34:14 PM »

My girlfriend's Equinox's passenger side wiper stopped working.  She went to Autozone, and they told her she needed a new wiper arm, which she ordered.  She expects me to replace it as soon as the new part arrives.  I am guessing it is simple, but I have to do it at her place, which means I can only use the tools I bring with me.  Does anyone here know what I need?
Logged
ChevyMgr
Sr. Member
****
Offline Offline

Gender: Male
Posts: 338




Ignore
« Reply #1 on: September 22, 2011, 01:25:43 PM »

What year?
Logged

Current Rides:
2011 Equinox LTZ - Born 11/5/2010 - Adopted 12/29/2010
2010 Malibu LTZ
2012 Cruze LT
2013 Cruze RS
bradvincent
Newbie
*
Offline Offline

Posts: 4




Ignore
« Reply #2 on: September 22, 2011, 01:38:35 PM »

2006
Logged
ChevyMgr
Sr. Member
****
Offline Offline

Gender: Male
Posts: 338




Ignore
« Reply #3 on: September 22, 2011, 04:47:19 PM »

Ok, I am guessing no warranty then. There is only one nut to remove. Sorry I don't know the exact size but something around a 10 or 11 mm I suspect. Here is a pic.

Logged

Current Rides:
2011 Equinox LTZ - Born 11/5/2010 - Adopted 12/29/2010
2010 Malibu LTZ
2012 Cruze LT
2013 Cruze RS
bradvincent
Newbie
*
Offline Offline

Posts: 4




Ignore
« Reply #4 on: September 28, 2011, 06:50:47 AM »

No warranty, and it isn't the arm.  Any ideas how to troubleshoot this?  There is only 1 motor for both wipers, correct?  If so, I know the motor is good since the driver side works.

How does the motor drive the wipers?  Where is the motor, and what is between it and the wipers?
Logged
Rit
Theta GOD!
********
Online Online

Gender: Male
Posts: 5918




Ignore
« Reply #5 on: September 28, 2011, 08:13:37 AM »

Is the shaft that the wiper arm slides onto turning?

If no, then it is probably the linkage for that arm that is broken.

If yes, then it is either the male or female spline that is stripped.  If you put on a new arm, then it it probably the  male spline that is stripped.  If neither looked stripped, then maybe the bolt that hold the wiper into the shaft is not tight enough.

You will have to watch it trying to operate, and figure out what is not correct.

Logged

2010 Equinox LTZ
4 cyl, FWD, S/R
Cardinal Red/Black
bradvincent
Newbie
*
Offline Offline

Posts: 4




Ignore
« Reply #6 on: September 28, 2011, 10:01:06 AM »

I am assuming the shaft is not turning and the linkage is broken.  There is a cowling under the hood, do I need to remove that to get at the linkage?  What else do I need to remove?

I don't have the vehicle, the only information I have to go by is what my girlfriend remembers the Autozone guy saying and what I remember from when I last saw it.
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines | Sitemap
©2014 EquinoxForum.net All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
Valid XHTML 1.0! Valid CSS!